All the ghost ship bugs people found so far

Discussion in 'Bug Reports' started by Jenkolegs, Dec 22, 2019.

  1. Jenkolegs

    Jenkolegs Rabby

    I am on meatshield version so beware spoilers!

    Stuff which I assume is placeholder:

    All the secret chests are constantly restocked with apples.

    The fridge and the blue eye minions are both called "Obsession". (They're quite obsessed with the word.)

    Johnathan's picnic portrait looks a bit off.

    Lots of audio is missing in most cut-scenes.

    Obsession item is a rag but says it's a card.

    Rolling eyes in cabin #15 are called Cacutes.

    Minor bugs:

    The captain's "disguise" can duplicate if you hit it fast enough. (I had shadow clone so it was easy.)

    Captain's head doesn't flash red when being hit. (May be due to it can be removed.)

    After the eye boss, the ghost barriers don't bounce you back. (Probably due to the actual boss arena.)

    The piano music continues outside the captain's quarters.

    Story quests hasn't updated at all. (Still says go to the harbour.)

    Twi-Sight reacts strangely with Ghosties - They can't change transparency but all stay killable.

    I still have Spring following me so this happened.

    The fridge has a health bar, so it spoils the surprise. (Ha, "spoils.")

    The shadow clone keeps "disconnecting" from me and forms shadows elsewhere.

    ShadowStuck.png ShadowLuke.png
    Major Bugs

    You can go faster than normal in your Startington? house by walking ~3 steps and stopping to slide, which is faster. Doing this and touching the globe and skipping the cutscene, I kept the slowness on the ship all the way to the boss. It reset when I died luckily.

    Luke can non-stop run into the left mast if you're standing near it. (Maybe could use for an exploit.)

    Game completely crashes when I try to read the #3 captain's log.

    Game stopped responding when Luke did a slam attack while the shadow clones were stuck.
    Teddy likes this.
  2. Teddy

    Teddy Developer Staff Member

    Thanks for all the reports dude :D

    Did you notice any patterns of sorts, like was it at certain attacks by Luke this happened?

    Also what difficulty were you playing at, and did you play in single or in multiplayer?

    EDIT: Nevermind, I think I solved it! Seems like it was the smash balls of his throw that wouldn't get allocated new IDs.
    Last edited: Dec 23, 2019
  3. KoBeWi

    KoBeWi Jumpkin

    This is probably because their contents aren't implemented. But it really disappointed me (even though I knew this is coming!) when I got to the phase shift chest just for another apple :/ Since most of these chests will get unique items anyways, why not add some "Dummy items" that just have ID, but no real icon or description? This way testers who get to secret chests early will just have their new loot replaced with properly implemented items.

    btw, hijacking the thread for my own bugs
    I managed to make the wizard leave his spell effect after he died.

    The barrels in Fridge room don't cover the character.

    The spoopy Phase Plates become normal ones after one use.

    The downstairs door should have stairs down graphic.
  4. Jenkolegs

    Jenkolegs Rabby

    Hey I found a few more.

    Probably Intentional:

    The ghost boar during expectations goes through the left wall. (As it's a ghost that makes sense.)
    During the large staircase, going down leads to your room. (I thought that was the intentional way).
    You can't shoot the captain with the bow before the plank lands across the room.
    I think the cards say "Effect not implemented]"
    (Could just be me bad at reading, it won't even stay in the game anyway.)

    Minor Bugs:

    Walking on the bottom edge of the deck plays normal footsteps and not wet footsteps.

    Some gold somehow ended up on the wall in the 1st fight area.

    A tentacle from the puzzle block can appear in the normal world.

    The ghost skull wall appears under most of the areas.
    (Pictured 1 of them, they did happen elsewhere.)

    Hauntie's goop can appear over the wall.

    Skipping Luke's cut-scene results in Luke losing his axe.

    An actual crash:

    I found out
    (the hard way) that having the twi-sight turned on and repeatedly toggling it through a loading zone crashes the entire game.
  5. Jenkolegs

    Jenkolegs Rabby

    I changed the title 'cause you're contributing.
    Your welcome.
  6. Jenkolegs

    Jenkolegs Rabby

    It was in normal mode by myself, forgot to mention!
  7. Ulithium_Dragon

    Ulithium_Dragon Green Slime

    1) The mushrooms generated by the Mushroom Shield don't despawn after the boss fight with Luke, and can be triggered when the player moves around during the post-fight cutscene (which causes the screen to black out). For example, when the player moves to go throw the bracelet overboard.

    EDIT: Now that I think about it, I'm not entirely sure if this happens in other areas of the game after boss fights. It's pretty slim chance of this occurring, after all.

    2) You can get stuck in the blocks during the block moving puzzle in the dream version of Startington by pushing a block on top of yourself. It seems you can still escape by vibrating out, though.

    3) The first ghosts that spawn in these rooms can be attacked without being twilight shifted. All subsequent ghosts that spawn without leaving the map correctly cannot be attacked unless shifted.

    20191224010354_1.jpg 20191224011023_1.jpg
    - Happens on both difficulties.
    - I've beaten the whole ship (not sure when it started happening).

    EDIT: All of these occurred on single player.
    Last edited: Dec 25, 2019
  8. Jenkolegs

    Jenkolegs Rabby

    I found even more, this time with a buddy.
    Friend was hosting, and on normal mode.

    The pirate targeting icon was stuck on me after the boss fight.
    (It also appeared in Luke's boss fight too.)

    Some of the bouncing eye bomb's health bars stayed after explosions. My friend showed me he couldn't see them.

    My friends cabbage pet kept on getting stuck outside of doors. (This was the only capture I took)

    My friend couldn't twilight shift while phase shifting so he restarted the game and it worked.

    Here's a big one:
    After the Luke boss battle, my friend died and as the cut-scene happened with him but for me there was just a ghost standing in front of Luke. After the cut-scene, his idle stance and basic movement were as a ghost but everything else, (Charging, swinging, potion drinking, etc.), he turned into his normal character animations. He was even a ghost on the loading screens too.
  9. Jargalo

    Jargalo Rabby

    Alright, I've got a few:
    • I also had the floating ghost orbs stick around after the wizard died, as well as a few health orbs and such getting stuck in places I couldn't reach.
    • In fact, several of the bugs above I also encountered.
    • Most notably, Luke getting stuck, allowing me to cheese the fight (I think that's been fixed now).
    Mostly it's just minor graphical stuff, nothing game-breaking. I'll stay vigilant.
  10. res7less

    res7less Jumpkin

    This ladder's climbing box:

    - Craftable Ponchos require cores from Tai Ming instead of the Twilight Essences.

    - The 3 items from the illusion stay in the inventory.

    - Many enemies are still missing their frozen and stasis sprites.
    Last edited: Jan 4, 2020
  11. Faangzzz

    Faangzzz Green Slime

    After skipping the cutscene, Luke's axe wasn't on the ground upload_2020-1-9_15-15-14.png
  12. Haribomann

    Haribomann Green Slime

    Game Mode: Normal
    Players: Two (over Internet)
    Location: "My" House in creepy startington

    1. slow-motion skip
    So I was playing with a friend and after finishing all the places in creepy Startington, we went back to our house. There was this slow-motion movement going on. I started blinking, which worked normally, but didn't seem to be intended.
    My friend used whirlslash and could also move in a normal speed with this skill.

    2. "Gather your friends"-bug in my room
    When I got to my room, the game told me to gather my friends constantly. I could not leave the room, but walk around or blink around somehwat normally, except that the room was not really there. The boundarys where there, but I could only see stars and very little furniture.
    My friend came in as well and the request to gather my friends disappeared, but nothing else happened.
    We tried this, before being able to move normally.
    We quit the game after a while of walkind around in the room and nothing happening.

    So we started up again and this time waited for the cut-scene with dad to finish. Then we moved normally into our room, but the same problem happened again.
    When I started blinking around again, my friend said that the "gather your friends" popped up for him just a split second and disappeared again.
    So I blinked around some more and suddenly a cut-scene started.

    My guess is, that the trigger to gather my friends should be when trying to enter the room and then after entering the cut-scene should start immediately?
    Or was that intended?

    On a side not, we saw that the place is called "Startington?" which produced a laugh on my side :)
  13. Dellara

    Dellara Green Slime

    Don’t know if it has been mentioned or not, but I was fighting the eye boss and it got ‘nudged’ out of place, up to higher on the wall so I couldn’t attack it. Didn’t manage to get a screenshot, but if it happens again I’ll post it.

Share This Page