Game Deaded

Discussion in 'Bug Reports' started by Ghret, Sep 3, 2016.

Tags: appdata, bug, config, deaded,
  1. Ghret

    Ghret Green Slime

    The game deaded every time I start up the game and cant find an appdata file. I just bought the game and can't play it. I have tried many options. This is the event viewer error.
    Application: Secrets Of Grindea.exe
    Framework Version: v4.0.30319
    Description: The process was terminated due to an unhandled exception.
    Exception Info: System.IO.FileNotFoundException
    at <Module>.ImportXnaNativeMethod(Int32 ()*, SByte*)
    at Microsoft.Xna.Framework.Content.NativeMethods.CreateDecompressionContext()
    at Microsoft.Xna.Framework.Content.DecompressStream..ctor(System.IO.Stream, Int32, Int32)
    at Microsoft.Xna.Framework.Content.ContentReader.PrepareStream(System.IO.Stream, System.String, Int32 ByRef)

    Exception Info: Microsoft.Xna.Framework.Content.ContentLoadException
    at Microsoft.Xna.Framework.Content.ContentReader.PrepareStream(System.IO.Stream, System.String, Int32 ByRef)
    at Microsoft.Xna.Framework.Content.ContentReader.Create(Microsoft.Xna.Framework.Content.ContentManager, System.IO.Stream, System.String, System.Action`1<System.IDisposable>)
    at Microsoft.Xna.Framework.Content.ContentManager.ReadAsset[[System.__Canon, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]](System.String, System.Action`1<System.IDisposable>)
    at Microsoft.Xna.Framework.Content.ContentManager.Load[[System.__Canon, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]](System.String)
    at SoG.DialogueSystem.Init(Microsoft.Xna.Framework.Content.ContentManager)
    at SoG.Game1.Initialize()
    at Microsoft.Xna.Framework.Game.RunGame(Boolean)
    at SoG.Program.Main(System.String[])
     
    Last edited by a moderator: Sep 3, 2016
  2. Teddy

    Teddy Developer Staff Member

    Looks to be a corrupt/missing file!

    Is one of the things you've tried restarting Steam and then verifying the game's cache? (Right click on game in library, select properties, go to Local Files and then click Verify Integrity of Game Cache)
     
  3. Ghret

    Ghret Green Slime

    I have gone through this process and still the game gives me the same bug.
     
  4. Teddy

    Teddy Developer Staff Member

    If you're running any antivirus, have you tried disabling it?

    If you go into the game's local files (go into Steam properties, local files and click Browse local files to find it), what files can you see in the Content/GUI/Dialogue folder? It seems to be there the file can't be found!
     
  5. Ghret

    Ghret Green Slime

    I am not running an antivirus right now.
    In the content/GUI/Dialogue folder there is
    Portraits folder
    Svar folder
    Namnbricka.xnb
    Namnbricka_Large.xnb
    Pratruta.xnb
    Svar.xnb
    (in that order)
     
  6. Teddy

    Teddy Developer Staff Member

    In the "Svar" folder, are these files present?

    arrow.xnb
    Bot.xnb
    BotLeft.xnb
    Left.xnb
    Top.xnb
    TopLeft.xnb
    YourReply.xnb

    If they are, does the file path to the game folder contain any non-standard characters? Windows gives a "FileNotFoundException", but sometimes they bunch together errors so perhaps it simply can't understand the file path (I'm grasping for straws here).

    If none of the files are missing, and you have a perfectly standard file path, then there is probably some odd .NET issue at works. In that case I'd recommend refunding the game for now and trying again later down the road (by downloading the demo to see if it works) :(
     
  7. Ghret

    Ghret Green Slime

    It worked!
    Thanks for writing this here
    Also thanks for quick responses.
     
    Last edited by a moderator: Sep 4, 2016
    Teddy likes this.

Share This Page