[Gameplay] Twi-sight isn't working anymore

Discussion in 'Bug Reports' started by Weren, Apr 24, 2022.

  1. Weren

    Weren Green Slime

    Hello Grindea Team,

    I got the new ability twi-sight yesterday. I play on a keyboard so I rebind it as the D key. It worked perfectly until I log back in : it isn't bind to a key anymore. I tried to press space or any other key, I can't find it anywhere. I still have the item in my inventory but I can't do anything with it. I also tried to rebind it in the control menu : the ability is still there but it does not work. Even if I rebind it to any other key.

    I don't know if this matter but I logged out after I spoke with the captain next to the party room while I was in this mode.

    I hope this report can help.

    btw I love the game so far, it is really fun to play :)
     
    Last edited: Apr 25, 2022
  2. Teddy

    Teddy Developer Staff Member

    Hi, thanks for the report! That's super strange!

    Could you upload the save files (both the character and world file) in a .zip file to the forums so I can have a look? You can find the save files in %APPDATA%/Secrets of Grindea! Your first slot is named 0.cha and 0.wld, and so on.
     
  3. Weren

    Weren Green Slime

    Here you are !
     

    Attached Files:

    Teddy likes this.
  4. Teddy

    Teddy Developer Staff Member

    I've found the bug with your save, and have a fix for it! Type or copy-paste the following into the in-game chat:

    /toggleflag _MainStory_GhostShip_InPsychosis

    Basically what has happened is that your save for some reason thinks you're still in Captain Bones' curse-world!

    Did anything weird happen when you got out of it on this save? Like the game crashing, or if you remember exiting it at a "odd" timing (like in the middle of a cutscene)?
     
    Weren likes this.
  5. Weren

    Weren Green Slime

    Thank you :)

    I don't really remember honestly. The game didn't crash, that's for sure. I exited the game right after the Captain went in the other room, after speaking to him. I didn't follow him. Maybe I was still in the cutscene but I'm not sure.

    Edit : to clarify, I was at the base of the stairs. I just saw what happen after climbing them... If the entire scene begins just before climbing them, then I understand that it was an odd time to exit
     
    Last edited: Apr 26, 2022
    Teddy likes this.
  6. Teddy

    Teddy Developer Staff Member

    Thanks! Exiting right after meeting the captain was indeed what caused the bug! I've now added an extra spawn point there to make sure the player will return there if they quite before reaching the "Startington?" part :)
     
    Weren likes this.

Share This Page