[Gameplay/Crash] Unable to re-enter Evergrind City


Green Slime
I finished The Factory, Did the Fae quests, helped santa and tried to get back to Evergrind city to turn in the artifact, but it crashes every time I try to enter evergrind. It does not matter where I portal from, or which entrance i use, the game crashes during the loading animation.

I have added my world and char file as well.


  • char1.zip
    3.8 KB · Views: 2

The G-Meister

Giga Slime
What do you mean by finished the Fae quests? Did you complete up to the Temple of Seasons? If so, there might be a problem in trying to load the sprites in Evergrind as it changes to the festival preparations. /dragonreset might help you, but I wouldn't do that unless you're desperate. With my experience with the reset commands they either lock you inside the festival or do absolutely nothing.


Staff member
@Ryushie Before I load up your files, have you tried restarting Steam and then verifying the game's cache? (Right click on game in library, select properties, go to Local Files and then click Verify Integrity of Game Cache)

Might be some festival preparation sprite that's corrupt!


Green Slime
Integrity check found 1 bad file, Repaired it and was able to load Evergrind. Thank you for the quick responses.