How to add support for glyph heavy languages (Chinese, Japanese, Korean etc)

Discussion in 'Translation Tools' started by Teddy, May 6, 2014.

  1. TsReaper

    TsReaper Boar

    I've only translated about 19% of misc texts.
    I've translated most of the enemy drops in Pillar Mountain, so maybe it's a good idea to test with actual translations in Pillar Mountain.
    About skills, I've only translated the texts about Cloud Strike.

    Another problem: The game can show the description of unknown items/enemies correctly, but it can't show the description of unknown cards.

    Thanks again for giving support to Chinese in the game.
     

    Attached Files:

    Last edited: Feb 18, 2016
    Teddy likes this.
  2. Teddy

    Teddy Developer Staff Member

    Thanks!

    I'll have a look at the issues in game and try to fix most of the issues for the next update (when Mt Bloom gets its side quests etc)!

    As you said, focusing on translating dialogue is probably the best bet until I've sorted out these issues.
     
    TsReaper likes this.
  3. TsReaper

    TsReaper Boar

    Another two problems:
    problem1.png problem2.png problem3.png
    Although it's a little strange that picture3 can show one character correctly.
     
  4. TsReaper

    TsReaper Boar

    And more...
    problem.png
     
  5. TsReaper

    TsReaper Boar

    How weird. Today I'm translation texts about skills and suddenly discovered that skill descriptions can be correctly displayed. (Just a few days ago I can't translate them, see #19. The down arrow key also functions well, see #7, but the problem in the description of Bloomo still exists.) Have you updated the translation tools? @Teddy
    correct2.png

    And still another problem. All but two skill names can be correctly displayed. The two skill names are Crippling Blast and Snap Cast. The font it displays is not my custom font either.
    correct.png
    (Correct display)

    problem.png
    (Incorrect display)

    pic.png
     
    Last edited: Mar 22, 2016
  6. Teddy

    Teddy Developer Staff Member

    Some of these issues might be due to two things, which are a bit hard to explain. It's related to the manual font building in the final tab of the translation tools.

    How they work is they go through all the translated texts that is flagged as the selected font, and compile a large list of what characters were used. They then build a font that has only these characters in it.

    So, one possible reason for these issues is that I've accidentally called on the wrong font when rendering sometimes, like using BoldTitle instead of SmallTitle (not sure these are the actual names!)

    If, in that case, the BoldTitle font does not contain the correct characters through a fluke, it doesn't know how to render the text properly, as the characters needed exists in the SmallTitle font.

    Conversely, even if BoldTitle doesn't include a specific translated text, it might contain a lot of other texts that by chance includes some or all of the required characters. In that case the text can be rendered, but it's because of luck and nothing else. The more of the game that's translated, the bigger the risk/chance of this happening since there are a bigger set of glyphs in each font.

    Another thing might be if you yourself forgot to remake the fonts after adding a bunch of new translations! It would almost seem that way in the specific case of the skill description, since it's so many different characters and none of them render as "?", but it could still be a fluke of course.

    Solution on my end

    One thing I might have to do is make it possible for a translated text to belong to more than one font, so I can use Label and SmallTitle for item names in different contexts, for example. This will require an update of the tools, but won't affect the translator's job very much!

    At other places, there's probably bugs in the code, where I've simply used the wrong font for the job!
     
    TsReaper likes this.
  7. hitoys

    hitoys Green Slime

    Translation program isn't working on this 0.612 upadate.
    I try to erase and install the game and translation program.
    Game is work, but when i run the translation program, it is not respond.
    What's happened??
     
  8. Teddy

    Teddy Developer Staff Member

    Have you managed to start the program before successfully, and started making a translation? If so, did you use a custom image for it?

    Also, can you see any errors for the game in the Event Viewer? You can open it up by bringing up the Windows start menu and typing eventvwr. Then go into Windows Logs->Application and look for errors related to Secrets of Grindea! The .NET Runtime errors are most useful.
     
  9. GRomPES

    GRomPES Green Slime

    The problem with the display of Cyrillic. Instead of win 1251, it's better to use UTF 8
     

    Attached Files:

  10. BlueOnion439

    BlueOnion439 Green Slime

    I tried to install Microsoft Visual C# 2010 Express from the link, but it says "To install this product, please run Setup.exe. For other installation options, see the Installation section of ReadMe.htm." and doesn't work. And XNA Game Studio 4.0 Installation requires Visual C# Express. Are those files unable to use now?

    I'm using Windows 10, And trying to translate Korean. I know Korean translation is already exist, but its latest update is 2017.09.01, so it's likely outdated.
     
  11. TsReaper

    TsReaper Boar

    It seems that Microsoft Visual C# 2010 is too outdated for Windows 10. I install it in a Windows 7 virtual machine and do all the rendering stuff in it.
     
  12. BlueOnion439

    BlueOnion439 Green Slime

    I've installed Windows 7 Home Premium on Oracle VM VirtualBox and have tried installing it, but it didn't work either. Also XNA Game Studio 4.0 Setup provided requirement program download link (http://go.microsoft.com/fwlink/?LinkId=182981), which the file doesn't even exist. I think both files are completely gone nowadays.
     
  13. Teddy

    Teddy Developer Staff Member

    Strange that it doesn't seem to be working to install VS2010 even in the Win7 virtual machine!

    The XNA Game Studio setup is probably complaining about missing a Visual Studio installation, so my guess is that any Visual Studio version will solve that problem (on my Win10 machine I use VS2015 with XNA).

    There are free versions available for the current versions as well. I've been linking the VS2010 one mostly because it's the fastest to install! When it worked, anyway.

    On your virtual machine, can you download and install from this link? https://visualstudio.microsoft.com/thank-you-downloading-visual-studio/?sku=Community&rel=15
     
  14. BlueOnion439

    BlueOnion439 Green Slime

    Visual Studio Community 2017 was successfully downloaded, but XNA Game Studio 4.0 setup is still unable to continue because of missing requirements.

    I wonder how the person who made Korean translation managed this problem. I wish I could ask him or her about it...
     
  15. Teddy

    Teddy Developer Staff Member

    Does it state what the missing requirements are, or does it just say "missing requirements" and provide that broken link?
     
  16. BlueOnion439

    BlueOnion439 Green Slime

    "The Setup Wizard will install Microsoft XNA Game Studio 4.0 on your computer. Click Next to continue or Cancel to exit the Setup Wizard." I pressed Next, and then..


    Missing Requirements

    The following requirements were not met.
    These requirements must be resolved prior to installing Microsoft XNA Game Studio 4.0:

    Install Windows Phone Developer Tools, Visual Studio 2010 or Visual C# 2010 Express
     
  17. Teddy

    Teddy Developer Staff Member

    Interesting... I found some people have made a workaround by unpacking the Game Studio installer - perhaps that will work? In the list, I think you only need to follow the steps 1-3 since the Visual Studio installation is just for show anyway.

    Here's the link: http://flatredball.com/visual-studio-2017-xna-setup/

    Can you install the stuff in the .zip?
     
  18. BlueOnion439

    BlueOnion439 Green Slime

    And.. It finally works! Thank you for your kind help, and I will do my best to make 100% Korean translation (Including Arcade mode)!
     

    Attached Files:

    Teddy likes this.
  19. Teddy

    Teddy Developer Staff Member

    Awesome - thanks for sticking with it and helping find the solution!

    I'll update the instruction post to use this new method.
     
    BlueOnion439 likes this.

Share This Page